Op Elektronicaforum.nl is de kans om een antwoord op je vraag te krijgen heel groot. In overzichtelijke subcategorieën kun je vragen en antwoorden over elektronica zoeken, plaatsen en beantwoorden.
Elektronica Forum is onderdeel van Schakelingen Online
 


 
Defecte robotmaaier

 
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> Elektronica algemeen
Auteur Bericht
Joeri Fr



Geregistreerd op: 29-9-2004
Berichten: 741
Woonplaats: Brugge (B)

BerichtGeplaatst: Do 30 Mei 2019, 16:03    Onderwerp: Defecte robotmaaier Reageer met quote

Hallo,
onze robotmaaier doet het niet meer na zijn winterslaap.
De maaier heeft 2 sensoren (spoeltjes, 150 Ohm elk) vooraan, waarmee hij een perimeterdraad aftast.
Je kan op het scherm aflezen wanneer de sensoren over de draad gaan (binnen de draad krijg je waarde 400, buiten de draad 200, en als de draad is uitgeschakeld is de waarde nul (volgens service manual).
De voeding is verbonden met het oplaadstation, en daar hangt de perimeterdraad aan.

Gister en vanmorgen deed ie het even, maar gaf na 10 minuten foutmelding dat er geen perimeterdraad is.

Ik heb dan een en ander bekeken;
- op de maaier; sensorspoelen zijn 150 Ohm, dus niet defect denk ik.
- de draadlus heeft een weerstand van 7 Ohm, wat correct is voor zn lengte.
- De voeding geeft 34V naar het oplaadstation; is ok. De maaier laadt correct op aan het laadstation.
- Wanneer de maaier niet oplaadt, zit er een PWM tussen -34V en +34V van voeding naar laadstation, met ongeveer een f = 4kHz. Nu en dan is er een burst met hogere frequentie van ongeveer 40kHz, maar die slechts +/-0.8ms aan. Daarna is er 0,5ms niets, en dan begint de 4kHz PWM terug. Zie beeld https://i.postimg.cc/sgVN3Tmg/uitgang-PSU-naar-laadkop.gif

Om te testen heb ik een lus van 5m gemaakt met de maaier in het midden.
- Als ik een probe aan de perimeterdraad hang, zie ik het beeld 'draadlus' op mn oscilloscoop. https://i.postimg.cc/tTVrBwq2/draadlus.jpg
De amplitude van het signaal is tussen 1 en 2V. Lijkt me erg laag.
- De sensoren van de maaier vangen niets op (blijven op nul). Maar wanneer ik perimeterdraad tegen een sensor houd, dan gaat de waarde naar 400 op het scherm.

De prinplaat van de laadkop krijgt de 34V PWM binnen van de voeding.
op die print zit een kleine schakeling met IR-leds om de maaier naar het basisstation te krijgen.
Tevens zitten er een paar grote R's op die 83 Ohm vormen met een 0,18µF C in serie. Dit vormt de kring voor de perimeterdraad (+34V PWM op R 83 Ohm en C 0,18µF in serie, en dan perimeterdraad 7 Ohm in serie als antenne).
f res= 1/(2*pi*R*C) = 1/ (2*pi*(83+7)*0,18e-6)= +/-10kHz ?
Ik heb de C eruit gesoldeerd en gemeten en deze is mooi 0,19µF.

Iemand een idee of de lage amplitude op de draadlus normaal is?
Of klopt de 4kHz die nu en dan 40kHz wordt niet met de RC resonantie van 10kHz?
En indien niet, hoe ik kan checken wat er defect is?
Ik ken niet veel van antenne's enzo... Embarassed
Alvast dank!

PS: uploaden van de oscilloscoop jpg beelden lukt niet...foutmelding op de site.


Laatst aangepast door Joeri Fr op Do 30 Mei 2019, 18:02, in totaal 1 keer bewerkt
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
bertus
Moderator
Moderator


Geregistreerd op: 14-2-2007
Berichten: 2353
Woonplaats: Amsterdam

BerichtGeplaatst: Do 30 Mei 2019, 17:52    Onderwerp: Reageer met quote

Hallo,

Ik heb de problemen met het uploaden van plaatjes al gemeld.
Als je toch plaatjes wilt tonen kun je postimage gebruiken en een link hier plaatsen.
https://postimages.org/

Bertus
_________________
Je hoeft niet alles te weten,als je het maar weet te vinden.
Als je iets vraagt lijk je misschien dom.
Als je niets vraagt blijf je dom.

Ik beantwoord geen vragen in PM's.
Dit gaat voorbij aan de ideeen van het forum,
het delen van informatie.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Joeri Fr



Geregistreerd op: 29-9-2004
Berichten: 741
Woonplaats: Brugge (B)

BerichtGeplaatst: Do 30 Mei 2019, 18:03    Onderwerp: Reageer met quote

Thanks. Dat wist ik niet Confused
Ik heb de links erbij gezet.
Helpt dit om het probleem te vinden?
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
smd_lover
Moderator
Moderator


Geregistreerd op: 24-3-2009
Berichten: 1648
Woonplaats: prov Groningen.

BerichtGeplaatst: Do 30 Mei 2019, 18:12    Onderwerp: Reageer met quote

Je hebt het mooi gedetailleerd neergezet, maar er moet maar net iemand kijken die weet hoe het signaal eruit hoort te zien.

Kan het niet gewoon een slechte accu zijn? Dat hij bij lage accuspanning deze foutmelding geeft?
_________________
Hoe zorgvuldiger je als topicstarter je probleem omschrijft, hoe meer kans op adequate reacties en een oplossing.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Joeri Fr



Geregistreerd op: 29-9-2004
Berichten: 741
Woonplaats: Brugge (B)

BerichtGeplaatst: Do 30 Mei 2019, 18:18    Onderwerp: Reageer met quote

Nee, de accu is het probleem niet. Ze is opgeladen en tevens zie je dat ze 4,5 Ah heeft.

Ik zou graag weten wanneer de voeding dat 4 kHz signaal afgeeft, dat dan over de RC met 83 Ohm en 180nF loopt (10kHz resonantie?), het dan goed is wat over de perimeterdraad wordt gemeten?

Lijkt me iets voor Mat... Very Happy
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Joeri Fr



Geregistreerd op: 29-9-2004
Berichten: 741
Woonplaats: Brugge (B)

BerichtGeplaatst: Di 4 Jun 2019, 13:31    Onderwerp: Reageer met quote

Niemand een idee?
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Joeri Fr



Geregistreerd op: 29-9-2004
Berichten: 741
Woonplaats: Brugge (B)

BerichtGeplaatst: Di 11 Jun 2019, 20:13    Onderwerp: Reageer met quote

Ik heb t zelf gevonden. Topic mag dicht.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
bertus
Moderator
Moderator


Geregistreerd op: 14-2-2007
Berichten: 2353
Woonplaats: Amsterdam

BerichtGeplaatst: Di 11 Jun 2019, 21:19    Onderwerp: Reageer met quote

Hallo,

Wat was het probleem?
Kun je de oplossing posten?
Dan hebben anderen er ook mogelijk profijt van.

Bertus
_________________
Je hoeft niet alles te weten,als je het maar weet te vinden.
Als je iets vraagt lijk je misschien dom.
Als je niets vraagt blijf je dom.

Ik beantwoord geen vragen in PM's.
Dit gaat voorbij aan de ideeen van het forum,
het delen van informatie.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> Elektronica algemeen Tijden zijn in GMT + 2 uur
Pagina 1 van 1                     

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen
Je mag geen reacties plaatsen
Je mag je berichten niet bewerken
Je mag je berichten niet verwijderen
Ja mag niet stemmen in polls
Je mag geen attachments plaatsen in dit forum
Je mag bestanden downloaden in dit forum


Powered by phpBB © 2001, 2002 phpBB Group and phpBB SEO